There has been no further errors since so I am marking this as resolved
Monitoring
Monitoring
It seems Fire is no longer getting 502's when sending messages meaning the issue was most likely linked to Discord's ongoing incident as the error rate calmed down after the most recent update.
I am continuing to monitor for any more errors
Investigating
Investigating
It seems Fire is having trouble sending some messages, particularly but not exclusively those with images.
This may or may not be related to Discord's ongoing incident but the API is still marked as operational.