Fire - Internal Server Error when attempting to join a Public Guild – Incident details

All systems operational

Internal Server Error when attempting to join a Public Guild

Resolved
Partial outage
Started over 4 years agoLasted 34 minutes
Updates
  • Resolved
    Resolved

    Seems everything is working fine now. If you're wondering what the issue was, Centra seems to send requests with an empty User Agent if you don't set one and I recently modified my firewall to block empty User Agents due to some attacks. Once that issue was resolved, another issue appeared, specifically involving permission checking. The API checks if the guild has enabled the public feature in Fire with the "$public" command or has the DISCOVERABLE feature but this seemed to be failing. Switching from bigints to strings seems to have resolved it though.

  • Monitoring
    Monitoring

    A fix has been implemented and we are monitoring the results.

  • Investigating
    Investigating

    While attempting to apply a patch, another issue has come up and is being investigated. I should have more details soon.

  • Identified
    Identified

    The issue has been identified and a temporary fix has been put in place. A full patch is being worked on.

  • Investigating
    Investigating

    It seems there's an issue with joining public guilds through FIre's public servers page. This issue is currently being investigated.