Fire - Emergency Maintenance: Changing Fire's cluster count – Incident details

All systems operational

Emergency Maintenance: Changing Fire's cluster count

Resolved
Operational
Started over 3 years agoLasted 31 minutes
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    A fix has been implemented and we are monitoring the results.

  • Identified
    Identified

    During this time, I will be restarting Fire to deploy bug fixes while also doubling the cluster count to 4 and having a shard per cluster. This will hopefully reduce delays during reboots and will allow me to have finer control over which servers get an update first. Fire will be offline for a couple minutes while I make these changes. I will eventually have a way to change the cluster & shard counts without complete downtime but did not find it was necessary as of yet.