Fire - Leave messages & logging not working – Incident details

All systems operational

Leave messages & logging not working

Resolved
Partial outage
Started over 4 years agoLasted 19 minutes
Updates
  • Resolved
    Resolved

    The fix, along with a fix for the fix (forgot to put await) has been deployed and leave messages & logging appear to be working. I've had to remove stayed for, nickname and roles from leave logging due to not having access to that data. I'm unsure on whether or not these will ever return since I don't want Fire caching a ton of members.

  • Update
    Update

    The fix is being deployed now. Fire will go offline for a few seconds while it restarts

  • Identified
    Identified

    It seems that the lack of cache has caused leave messages & logging to stop working. I have identified a possible fix and am working on implementing it now.